OpenWebBeans Tomcat 6, 7 and 8

Note: You also need other modules to run OpenWebBeans on Tomcat. These Tomcat plugins only adds extra features like injection into Servlets and are not even mandatory for running on Tomcat. For more information read Getting started.

Tomcat 6 Module

<dependency>
    <groupId>org.apache.openwebbeans</groupId>
    <artifactId>openwebbeans-tomcat6</artifactId>
    <version>${owb.version}</version>
    <scope>compile</scope>
</dependency>

Tomcat 7 and 8

<dependency>
    <groupId>org.apache.openwebbeans</groupId>
    <artifactId>openwebbeans-tomcat7</artifactId>
    <version>${owb.version}</version>
    <scope>compile</scope>
</dependency>